Talk to other MIDI Designer users about MIDI Designer, iOS MIDI and related topics. Or share layouts, pages, and ideas.

Also check out the Facebook Group.

Of course, if you want to send us an email, feel free.

MIDI Designer
Design your perfect MIDI controller for iPad, iPhone and iPod touch.
Panel Member Controls for Hide in Play Mode Not Hidden - MIDI Designer Q&A

Panel Member Controls for Hide in Play Mode Not Hidden

0 votes
asked Nov 30, 2020 in Defect (Confirmed, Not Fixed Yet) by adamixoye (500 points)
edited Jan 1 by MIDI Designer Team (Dan)
I'm not 100% following, but I made this.  Under 3 minutes long:  
oh! okay I see it, thanks, sorry for the slow uptake on my part.
Okay I forgot about this bug. Basically hide-in-play-mode isn't applying to controls ON panels until design mode entry exit.

So you have a workaround, of course, which is just to set the panel controls to "hide in play mode" which is far less convenient. I'll see if I can fix, thanks.
Oh, okay...well, that's weird, I feel a little silly for not thinking of that.

Yes, those five controls were on that panel and the panel was set to "hide in play mode" and this was happening.  When I set all of the individual controls on that panel to "hide in play mode" the behavior is the way I want it to be (they are hidden from startup).  So it's a better workaround than going into Design mode, though it's still a bug...
We've got a fix in place for this already, but it won't be coming to the Beta until 2.175 is ready. Hope you can sit tight, THANKS for reporting, it's a great find, actually. And happy new year!
...